PayPal Balances Not Refreshing with REST API
Incident Report for Trolley
Resolved
This incident has been resolved.
Posted Apr 25, 2024 - 16:16 UTC
Update
PayPal has acknowledged the issue and has escalated it internally.

Our recommendation stands from before:
> We recommend merchants still seeing PayPal balance issues to confirm they have "Transaction Search" enabled with their API keys via PayPal's Live App Settings, as detailed here: https://support.trolley.com/s/article/How-to-enroll-in-PayPal-Payouts-API. That update may take a few hours to persist, but if you still see issues, please reach out to support@trolley.com.
Posted Dec 28, 2023 - 21:53 UTC
Monitoring
We have seen the issue subside for a portion of our previously impacted merchants. We recommend merchants still seeing PayPal balance issues to confirm they have "Transaction Search" enabled with their API keys via PayPal's Live App Settings, as detailed here: https://support.trolley.com/s/article/How-to-enroll-in-PayPal-Payouts-API. That update may take a few hours to persist, but if you still see issues, please reach out to support@trolley.com.
Posted Dec 22, 2023 - 22:05 UTC
Investigating
We are currently having issues fetching balances via the PayPal REST API. The error we're seeing is "Authorization failed due to insufficient permissions."

We've reached out to PayPal to get more information on why we're seeing this message and we'll update here when we have more details.

Balance fetching using the Mass Payments (NVP/SOAP) credentials is still functional.
Posted Dec 21, 2023 - 22:54 UTC
This incident affected: Trolley API and Trolley Dashboard.