Trolley Live Chat is experiencing downtime
Incident Report for Trolley
Resolved
This incident has been resolved.
Posted Sep 05, 2024 - 19:02 UTC
Update
We are continuing to investigate this issue.
Posted Sep 05, 2024 - 18:43 UTC
Investigating
The Trolley Live Chat is experiencing issues at the moment and is unavailable.

We are investigating the cause and will provide an update here.

If you need assistance during this time, please reach out to us via email at support@trolley.com.

Thanks for your patience.
Posted Sep 05, 2024 - 18:43 UTC
This incident affected: Customer Support.