Payout Processing Delays

Incident Report for Trolley

Resolved

All systems are operating as expected again. Apologies for any trouble this caused.
Posted Sep 02, 2025 - 19:20 UTC

Monitoring

We have deployed a fix. Our system is picking back up to normal pace. The delays are expected to be reduced. We will continue to monitor. Please reach out to support if you're still encountering any issues.
Posted Sep 02, 2025 - 16:59 UTC

Investigating

We're currently investigating an issue that is causing payouts to have delayed processing times of 1h+. We'll keep you updated as we learn more and are able to resolve.
Posted Sep 02, 2025 - 16:02 UTC
This incident affected: Trolley Dashboard and Trolley API.